Dependency Convergence

Legend:
error At least one dependency has a differing version of the dependency or has SNAPSHOT dependencies.

Statistics:
Number of dependencies (NOD): 79
Number of unique artifacts (NOA): 100
Number of version-conflicting artifacts (NOC): 15
Number of SNAPSHOT artifacts (NOS): 13
Convergence (NOD/NOA): error 79 %
Ready for release (100 % convergence and no SNAPSHOTS): error Error
You do not have 100 % convergence.
You have SNAPSHOT dependencies.

Dependencies used in this project

com.google.guava:guava

error
18.0
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    \- org.xdi:oxtrust-scim:jar:4.0.0-SNAPSHOT:compile
       +- (com.google.guava:guava:jar:18.0:compile - omitted for conflict with 19.0)
       \- org.xdi:oxcore-service:jar:4.0.0-SNAPSHOT:compile
          \- (com.google.guava:guava:jar:18.0:compile - omitted for conflict with 19.0)

19.0
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    +- org.xdi:oxauth-client:jar:4.0.0-SNAPSHOT:compile
    |  \- com.google.guava:guava:jar:19.0:compile
    \- org.xdi:oxauth-model:jar:4.0.0-SNAPSHOT:compile
       +- (com.google.guava:guava:jar:19.0:compile - omitted for duplicate)
       \- org.gluu:oxeleven-client:jar:4.0.0-SNAPSHOT:compile
          \- (com.google.guava:guava:jar:19.0:compile - omitted for duplicate)

commons-codec:commons-codec

error
1.11
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    \- org.xdi:oxcore-util:jar:4.0.0-SNAPSHOT:compile
       \- (commons-codec:commons-codec:jar:1.11:compile - omitted for conflict with 1.7)

1.2
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    \- org.xdi:oxcore-util:jar:4.0.0-SNAPSHOT:compile
       \- commons-httpclient:commons-httpclient:jar:3.1:compile
          \- (commons-codec:commons-codec:jar:1.2:compile - omitted for conflict with 1.7)

1.7
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    +- org.xdi:oxauth-client:jar:4.0.0-SNAPSHOT:compile
    |  \- commons-codec:commons-codec:jar:1.7:compile
    \- org.xdi:oxauth-model:jar:4.0.0-SNAPSHOT:compile
       \- (commons-codec:commons-codec:jar:1.7:compile - omitted for duplicate)

commons-io:commons-io

error
2.5
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    \- org.xdi:oxauth-client:jar:4.0.0-SNAPSHOT:compile
       \- org.jboss.resteasy:resteasy-jaxrs:jar:3.0.21.Final:compile
          \- (commons-io:commons-io:jar:2.5:compile - omitted for conflict with 2.6)

2.6
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    +- org.xdi:oxauth-model:jar:4.0.0-SNAPSHOT:compile
    |  \- commons-io:commons-io:jar:2.6:compile
    \- org.xdi:oxcore-util:jar:4.0.0-SNAPSHOT:compile
       \- (commons-io:commons-io:jar:2.6:compile - omitted for duplicate)

commons-logging:commons-logging

error
1.0.4
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    \- org.xdi:oxcore-util:jar:4.0.0-SNAPSHOT:compile
       \- commons-httpclient:commons-httpclient:jar:3.1:compile
          \- (commons-logging:commons-logging:jar:1.0.4:compile - omitted for conflict with 1.2)

1.1.1
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    +- org.xdi:oxcore-util:jar:4.0.0-SNAPSHOT:compile
    |  \- commons-configuration:commons-configuration:jar:1.10:compile
    |     \- (commons-logging:commons-logging:jar:1.1.1:compile - omitted for conflict with 1.2)
    \- commons-beanutils:commons-beanutils:jar:1.8.3:compile
       \- commons-logging:commons-logging:jar:1.1.1:compile

javax.activation:activation

error
1.1
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    \- org.xdi:oxtrust-scim:jar:4.0.0-SNAPSHOT:compile
       \- org.xdi:oxcore-service:jar:4.0.0-SNAPSHOT:compile
          \- javax.mail:mail:jar:1.4.7:compile
             \- (javax.activation:activation:jar:1.1:compile - omitted for conflict with 1.1.1)

1.1.1
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    \- org.xdi:oxauth-client:jar:4.0.0-SNAPSHOT:compile
       \- org.jboss.resteasy:resteasy-jaxrs:jar:3.0.21.Final:compile
          \- javax.activation:activation:jar:1.1.1:compile

org.apache.httpcomponents:httpclient

error
4.5.2
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    \- org.xdi:oxauth-client:jar:4.0.0-SNAPSHOT:compile
       \- org.jboss.resteasy:resteasy-jaxrs:jar:3.0.21.Final:compile
          \- (org.apache.httpcomponents:httpclient:jar:4.5.2:compile - omitted for conflict with 4.5.3)

4.5.3
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    +- org.xdi:oxauth-client:jar:4.0.0-SNAPSHOT:compile
    |  \- org.apache.httpcomponents:httpclient:jar:4.5.3:compile
    \- org.xdi:oxauth-model:jar:4.0.0-SNAPSHOT:compile
       \- org.gluu:oxeleven-client:jar:4.0.0-SNAPSHOT:compile
          \- (org.apache.httpcomponents:httpclient:jar:4.5.3:compile - omitted for duplicate)

4.5.5
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    \- org.xdi:oxcore-util:jar:4.0.0-SNAPSHOT:compile
       \- (org.apache.httpcomponents:httpclient:jar:4.5.5:compile - omitted for conflict with 4.5.3)

org.apache.httpcomponents:httpcore

error
4.4.6
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    +- org.xdi:oxauth-client:jar:4.0.0-SNAPSHOT:compile
    |  +- org.apache.httpcomponents:httpclient:jar:4.5.3:compile
    |  |  \- (org.apache.httpcomponents:httpcore:jar:4.4.6:compile - omitted for duplicate)
    |  \- org.apache.httpcomponents:httpcore:jar:4.4.6:compile
    \- org.xdi:oxauth-model:jar:4.0.0-SNAPSHOT:compile
       \- org.gluu:oxeleven-client:jar:4.0.0-SNAPSHOT:compile
          \- (org.apache.httpcomponents:httpcore:jar:4.4.6:compile - omitted for duplicate)

4.4.9
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    \- org.xdi:oxcore-util:jar:4.0.0-SNAPSHOT:compile
       \- (org.apache.httpcomponents:httpcore:jar:4.4.9:compile - omitted for conflict with 4.4.6)

org.apache.logging.log4j:log4j-1.2-api

error
2.11.0
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    \- org.xdi:oxcore-util:jar:4.0.0-SNAPSHOT:compile
       \- (org.apache.logging.log4j:log4j-1.2-api:jar:2.11.0:compile - omitted for conflict with 2.8.2)

2.8.2
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    +- org.xdi:oxauth-client:jar:4.0.0-SNAPSHOT:compile
    |  \- org.apache.logging.log4j:log4j-1.2-api:jar:2.8.2:compile
    \- org.xdi:oxauth-model:jar:4.0.0-SNAPSHOT:compile
       \- (org.apache.logging.log4j:log4j-1.2-api:jar:2.8.2:compile - omitted for duplicate)

org.apache.logging.log4j:log4j-api

error
2.11.0
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    \- org.xdi:oxcore-util:jar:4.0.0-SNAPSHOT:compile
       +- (org.apache.logging.log4j:log4j-api:jar:2.11.0:compile - omitted for conflict with 2.8.2)
       \- org.apache.logging.log4j:log4j-slf4j-impl:jar:2.11.0:compile
          \- (org.apache.logging.log4j:log4j-api:jar:2.11.0:compile - omitted for conflict with 2.8.2)

2.8.2
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    +- org.xdi:oxauth-client:jar:4.0.0-SNAPSHOT:compile
    |  +- (org.apache.logging.log4j:log4j-api:jar:2.8.2:compile - omitted for duplicate)
    |  \- org.apache.logging.log4j:log4j-1.2-api:jar:2.8.2:compile
    |     \- (org.apache.logging.log4j:log4j-api:jar:2.8.2:compile - omitted for duplicate)
    +- org.xdi:oxauth-model:jar:4.0.0-SNAPSHOT:compile
    |  \- (org.apache.logging.log4j:log4j-api:jar:2.8.2:compile - omitted for duplicate)
    +- org.apache.logging.log4j:log4j-api:jar:2.8.2:compile
    \- org.apache.logging.log4j:log4j-core:jar:2.8.2:compile
       \- (org.apache.logging.log4j:log4j-api:jar:2.8.2:compile - omitted for duplicate)

org.apache.logging.log4j:log4j-core

error
2.11.0
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    +- org.xdi:oxcore-util:jar:4.0.0-SNAPSHOT:compile
    |  \- org.apache.logging.log4j:log4j-slf4j-impl:jar:2.11.0:compile
    |     \- (org.apache.logging.log4j:log4j-core:jar:2.11.0:runtime - omitted for conflict with 2.8.2)
    \- org.xdi:oxtrust-scim:jar:4.0.0-SNAPSHOT:compile
       \- (org.apache.logging.log4j:log4j-core:jar:2.11.0:compile - omitted for conflict with 2.8.2)

2.8.2
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    +- org.xdi:oxauth-client:jar:4.0.0-SNAPSHOT:compile
    |  +- org.apache.logging.log4j:log4j-1.2-api:jar:2.8.2:compile
    |  |  \- (org.apache.logging.log4j:log4j-core:jar:2.8.2:compile - omitted for duplicate)
    |  \- (org.apache.logging.log4j:log4j-core:jar:2.8.2:compile - omitted for duplicate)
    \- org.apache.logging.log4j:log4j-core:jar:2.8.2:compile

org.bouncycastle:bcprov-jdk15on

error
1.55
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    \- org.xdi:oxauth-client:jar:4.0.0-SNAPSHOT:compile
       +- (org.bouncycastle:bcprov-jdk15on:jar:1.55:compile - omitted for conflict with 1.59)
       \- org.bouncycastle:bcpkix-jdk15on:jar:1.55:compile
          \- (org.bouncycastle:bcprov-jdk15on:jar:1.55:compile - omitted for duplicate)

1.59
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    \- org.bouncycastle:bcprov-jdk15on:jar:1.59:compile

org.codehaus.jackson:jackson-core-asl

error
1.9.11
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    +- org.xdi:oxauth-client:jar:4.0.0-SNAPSHOT:compile
    |  \- (org.codehaus.jackson:jackson-core-asl:jar:1.9.11:compile - scope updated from runtime; omitted for duplicate)
    +- org.xdi:oxauth-model:jar:4.0.0-SNAPSHOT:compile
    |  \- (org.codehaus.jackson:jackson-core-asl:jar:1.9.11:compile - omitted for conflict with 1.9.13)
    \- org.xdi:oxtrust-scim:jar:4.0.0-SNAPSHOT:compile
       \- (org.codehaus.jackson:jackson-core-asl:jar:1.9.11:compile - omitted for duplicate)

1.9.13
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    +- org.xdi:oxauth-model:jar:4.0.0-SNAPSHOT:compile
    |  \- org.xdi:oxcore-model:jar:4.0.0-SNAPSHOT:compile
    |     \- (org.codehaus.jackson:jackson-core-asl:jar:1.9.13:compile - omitted for duplicate)
    +- org.xdi:oxcore-util:jar:4.0.0-SNAPSHOT:compile
    |  +- (org.codehaus.jackson:jackson-core-asl:jar:1.9.13:compile - omitted for conflict with 1.9.11)
    |  \- org.jboss.resteasy:resteasy-jackson-provider:jar:3.0.24.Final:compile
    |     +- (org.codehaus.jackson:jackson-core-asl:jar:1.9.13:compile - omitted for conflict with 1.9.11)
    |     +- org.codehaus.jackson:jackson-jaxrs:jar:1.9.13:compile
    |     |  \- (org.codehaus.jackson:jackson-core-asl:jar:1.9.13:compile - omitted for conflict with 1.9.11)
    |     \- org.codehaus.jackson:jackson-xc:jar:1.9.13:compile
    |        \- (org.codehaus.jackson:jackson-core-asl:jar:1.9.13:compile - omitted for conflict with 1.9.11)
    +- org.codehaus.jackson:jackson-core-asl:jar:1.9.13:compile
    \- org.codehaus.jackson:jackson-mapper-asl:jar:1.9.13:compile
       \- (org.codehaus.jackson:jackson-core-asl:jar:1.9.13:compile - omitted for duplicate)

org.codehaus.jackson:jackson-mapper-asl

error
1.9.11
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    +- org.xdi:oxauth-client:jar:4.0.0-SNAPSHOT:compile
    |  \- (org.codehaus.jackson:jackson-mapper-asl:jar:1.9.11:compile - scope updated from runtime; omitted for duplicate)
    +- org.xdi:oxauth-model:jar:4.0.0-SNAPSHOT:compile
    |  \- (org.codehaus.jackson:jackson-mapper-asl:jar:1.9.11:compile - omitted for conflict with 1.9.13)
    \- org.xdi:oxtrust-scim:jar:4.0.0-SNAPSHOT:compile
       \- (org.codehaus.jackson:jackson-mapper-asl:jar:1.9.11:compile - omitted for duplicate)

1.9.13
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    +- org.xdi:oxcore-util:jar:4.0.0-SNAPSHOT:compile
    |  +- (org.codehaus.jackson:jackson-mapper-asl:jar:1.9.13:compile - omitted for conflict with 1.9.11)
    |  \- org.jboss.resteasy:resteasy-jackson-provider:jar:3.0.24.Final:compile
    |     +- (org.codehaus.jackson:jackson-mapper-asl:jar:1.9.13:compile - omitted for conflict with 1.9.11)
    |     +- org.codehaus.jackson:jackson-jaxrs:jar:1.9.13:compile
    |     |  \- (org.codehaus.jackson:jackson-mapper-asl:jar:1.9.13:compile - omitted for conflict with 1.9.11)
    |     \- org.codehaus.jackson:jackson-xc:jar:1.9.13:compile
    |        \- (org.codehaus.jackson:jackson-mapper-asl:jar:1.9.13:compile - omitted for conflict with 1.9.11)
    \- org.codehaus.jackson:jackson-mapper-asl:jar:1.9.13:compile

org.jboss.resteasy:resteasy-jackson-provider

error
3.0.21.Final
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    +- org.xdi:oxauth-client:jar:4.0.0-SNAPSHOT:compile
    |  \- (org.jboss.resteasy:resteasy-jackson-provider:jar:3.0.21.Final:compile - scope updated from runtime; omitted for duplicate)
    \- org.xdi:oxauth-model:jar:4.0.0-SNAPSHOT:compile
       \- org.gluu:oxeleven-client:jar:4.0.0-SNAPSHOT:compile
          \- (org.jboss.resteasy:resteasy-jackson-provider:jar:3.0.21.Final:compile - omitted for conflict with 3.0.24.Final)

3.0.24.Final
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    \- org.xdi:oxcore-util:jar:4.0.0-SNAPSHOT:compile
       \- org.jboss.resteasy:resteasy-jackson-provider:jar:3.0.24.Final:compile

org.slf4j:slf4j-api

error
1.7.10
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    \- org.xdi:oxtrust-scim:jar:4.0.0-SNAPSHOT:compile
       \- org.xdi:oxcore-service:jar:4.0.0-SNAPSHOT:compile
          \- org.quartz-scheduler:quartz:jar:2.3.0:compile
             \- com.zaxxer:HikariCP-java6:jar:2.3.13:compile
                \- (org.slf4j:slf4j-api:jar:1.7.10:compile - omitted for conflict with 1.7.25)

1.7.25
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    +- org.xdi:oxcore-util:jar:4.0.0-SNAPSHOT:compile
    |  \- org.slf4j:slf4j-api:jar:1.7.25:compile
    \- org.xdi:oxtrust-scim:jar:4.0.0-SNAPSHOT:compile
       \- org.xdi:oxcore-service:jar:4.0.0-SNAPSHOT:compile
          \- io.dropwizard.metrics:metrics-core:jar:4.0.2:compile
             \- (org.slf4j:slf4j-api:jar:1.7.25:compile - omitted for duplicate)

1.7.7
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    \- org.xdi:oxtrust-scim:jar:4.0.0-SNAPSHOT:compile
       \- org.xdi:oxcore-service:jar:4.0.0-SNAPSHOT:compile
          \- org.quartz-scheduler:quartz:jar:2.3.0:compile
             \- (org.slf4j:slf4j-api:jar:1.7.7:compile - omitted for conflict with 1.7.25)

1.8.0-alpha2
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    \- org.xdi:oxcore-util:jar:4.0.0-SNAPSHOT:compile
       \- org.apache.logging.log4j:log4j-slf4j-impl:jar:2.11.0:compile
          \- (org.slf4j:slf4j-api:jar:1.8.0-alpha2:compile - omitted for conflict with 1.7.25)

org.gluu:oxeleven-client

error
4.0.0-SNAPSHOT
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    \- org.xdi:oxauth-model:jar:4.0.0-SNAPSHOT:compile
       \- org.gluu:oxeleven-client:jar:4.0.0-SNAPSHOT:compile

org.gluu:oxeleven-model

error
4.0.0-SNAPSHOT
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    \- org.xdi:oxauth-model:jar:4.0.0-SNAPSHOT:compile
       +- org.gluu:oxeleven-client:jar:4.0.0-SNAPSHOT:compile
       |  \- (org.gluu:oxeleven-model:jar:4.0.0-SNAPSHOT:compile - omitted for duplicate)
       \- org.gluu:oxeleven-model:jar:4.0.0-SNAPSHOT:compile

org.xdi:oxauth-client

error
4.0.0-SNAPSHOT
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    \- org.xdi:oxauth-client:jar:4.0.0-SNAPSHOT:compile

org.xdi:oxauth-model

error
4.0.0-SNAPSHOT
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    +- org.xdi:oxauth-client:jar:4.0.0-SNAPSHOT:compile
    |  \- (org.xdi:oxauth-model:jar:4.0.0-SNAPSHOT:compile - omitted for duplicate)
    \- org.xdi:oxauth-model:jar:4.0.0-SNAPSHOT:compile

org.xdi:oxcore-filter

error
4.0.0-SNAPSHOT
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    \- org.xdi:oxtrust-scim:jar:4.0.0-SNAPSHOT:compile
       \- org.xdi:oxcore-service:jar:4.0.0-SNAPSHOT:compile
          \- org.xdi:oxcore-ldap:jar:4.0.0-SNAPSHOT:compile
             +- org.xdi:oxcore-filter:jar:4.0.0-SNAPSHOT:compile
             \- org.xdi:oxcore-persist:jar:4.0.0-SNAPSHOT:compile
                \- (org.xdi:oxcore-filter:jar:4.0.0-SNAPSHOT:compile - omitted for duplicate)

org.xdi:oxcore-ldap

error
4.0.0-SNAPSHOT
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    \- org.xdi:oxtrust-scim:jar:4.0.0-SNAPSHOT:compile
       \- org.xdi:oxcore-service:jar:4.0.0-SNAPSHOT:compile
          \- org.xdi:oxcore-ldap:jar:4.0.0-SNAPSHOT:compile

org.xdi:oxcore-ldap-annotations

error
4.0.0-SNAPSHOT
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    +- org.xdi:oxauth-model:jar:4.0.0-SNAPSHOT:compile
    |  +- org.xdi:oxcore-ldap-annotations:jar:4.0.0-SNAPSHOT:compile
    |  \- org.xdi:oxcore-model:jar:4.0.0-SNAPSHOT:compile
    |     +- (org.xdi:oxcore-ldap-annotations:jar:4.0.0-SNAPSHOT:compile - omitted for duplicate)
    |     \- org.xdi:oxcore-persist-model:jar:4.0.0-SNAPSHOT:compile
    |        \- (org.xdi:oxcore-ldap-annotations:jar:4.0.0-SNAPSHOT:compile - omitted for duplicate)
    +- org.xdi:oxcore-util:jar:4.0.0-SNAPSHOT:compile
    |  \- (org.xdi:oxcore-ldap-annotations:jar:4.0.0-SNAPSHOT:compile - omitted for duplicate)
    \- org.xdi:oxtrust-scim:jar:4.0.0-SNAPSHOT:compile
       +- (org.xdi:oxcore-ldap-annotations:jar:4.0.0-SNAPSHOT:compile - omitted for duplicate)
       \- org.xdi:oxcore-service:jar:4.0.0-SNAPSHOT:compile
          \- org.xdi:oxcore-ldap:jar:4.0.0-SNAPSHOT:compile
             +- org.xdi:oxcore-persist:jar:4.0.0-SNAPSHOT:compile
             |  \- (org.xdi:oxcore-ldap-annotations:jar:4.0.0-SNAPSHOT:compile - omitted for duplicate)
             \- (org.xdi:oxcore-ldap-annotations:jar:4.0.0-SNAPSHOT:compile - omitted for duplicate)

org.xdi:oxcore-model

error
4.0.0-SNAPSHOT
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    +- org.xdi:oxauth-model:jar:4.0.0-SNAPSHOT:compile
    |  \- org.xdi:oxcore-model:jar:4.0.0-SNAPSHOT:compile
    \- org.xdi:oxtrust-scim:jar:4.0.0-SNAPSHOT:compile
       \- org.xdi:oxcore-service:jar:4.0.0-SNAPSHOT:compile
          \- (org.xdi:oxcore-model:jar:4.0.0-SNAPSHOT:compile - omitted for duplicate)

org.xdi:oxcore-persist

error
4.0.0-SNAPSHOT
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    \- org.xdi:oxtrust-scim:jar:4.0.0-SNAPSHOT:compile
       \- org.xdi:oxcore-service:jar:4.0.0-SNAPSHOT:compile
          \- org.xdi:oxcore-ldap:jar:4.0.0-SNAPSHOT:compile
             \- org.xdi:oxcore-persist:jar:4.0.0-SNAPSHOT:compile

org.xdi:oxcore-persist-model

error
4.0.0-SNAPSHOT
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    +- org.xdi:oxauth-model:jar:4.0.0-SNAPSHOT:compile
    |  \- org.xdi:oxcore-model:jar:4.0.0-SNAPSHOT:compile
    |     \- org.xdi:oxcore-persist-model:jar:4.0.0-SNAPSHOT:compile
    \- org.xdi:oxtrust-scim:jar:4.0.0-SNAPSHOT:compile
       \- org.xdi:oxcore-service:jar:4.0.0-SNAPSHOT:compile
          \- org.xdi:oxcore-ldap:jar:4.0.0-SNAPSHOT:compile
             \- org.xdi:oxcore-persist:jar:4.0.0-SNAPSHOT:compile
                \- (org.xdi:oxcore-persist-model:jar:4.0.0-SNAPSHOT:compile - omitted for duplicate)

org.xdi:oxcore-service

error
4.0.0-SNAPSHOT
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    \- org.xdi:oxtrust-scim:jar:4.0.0-SNAPSHOT:compile
       \- org.xdi:oxcore-service:jar:4.0.0-SNAPSHOT:compile

org.xdi:oxcore-util

error
4.0.0-SNAPSHOT
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    +- org.xdi:oxauth-model:jar:4.0.0-SNAPSHOT:compile
    |  +- (org.xdi:oxcore-util:jar:4.0.0-SNAPSHOT:compile - omitted for duplicate)
    |  \- org.xdi:oxcore-model:jar:4.0.0-SNAPSHOT:compile
    |     \- org.xdi:oxcore-persist-model:jar:4.0.0-SNAPSHOT:compile
    |        \- (org.xdi:oxcore-util:jar:4.0.0-SNAPSHOT:compile - omitted for duplicate)
    +- org.xdi:oxcore-util:jar:4.0.0-SNAPSHOT:compile
    \- org.xdi:oxtrust-scim:jar:4.0.0-SNAPSHOT:compile
       \- org.xdi:oxcore-service:jar:4.0.0-SNAPSHOT:compile
          +- org.xdi:oxcore-ldap:jar:4.0.0-SNAPSHOT:compile
          |  +- (org.xdi:oxcore-util:jar:4.0.0-SNAPSHOT:compile - omitted for duplicate)
          |  +- org.xdi:oxcore-filter:jar:4.0.0-SNAPSHOT:compile
          |  |  \- (org.xdi:oxcore-util:jar:4.0.0-SNAPSHOT:compile - omitted for duplicate)
          |  \- org.xdi:oxcore-persist:jar:4.0.0-SNAPSHOT:compile
          |     \- (org.xdi:oxcore-util:jar:4.0.0-SNAPSHOT:compile - omitted for duplicate)
          \- (org.xdi:oxcore-util:jar:4.0.0-SNAPSHOT:compile - omitted for duplicate)

org.xdi:oxtrust-scim

error
4.0.0-SNAPSHOT
    gluu.scim.client:scim-client2:jar:4.0.0-SNAPSHOT
    \- org.xdi:oxtrust-scim:jar:4.0.0-SNAPSHOT:compile